System maintenance (Education)

Incident Report for MindBridge

Resolved

This incident has been resolved.
Posted May 09, 2025 - 20:43 UTC

Investigating

MindBridge system maintenance has been scheduled for quiet hours in the Education environment.

Downtime is estimated to last approximately 30 minutes.
Posted May 09, 2025 - 20:34 UTC
This incident affected: MindBridge Application (Education).