Impersonation notice

Incident Report for MindBridge

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 22:24 UTC

Monitoring

We are aware of a fraudulent website impersonating MindBridge Analytics Inc. through a look-alike domain. Our official login site is login.mindbridge.ai. Do not enter credentials or payment information on any other site.
Posted Aug 31, 2026 - 20:41 UTC